import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((Monday|Tuesday|Wednesday|Thursday|Friday|Saturday|Sunday)(?!.*\\2)(, |$))*$";
final String string = "Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday\n"
+ "Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Saturday\n"
+ "Monday, Tuesday, Wednesday, Thursday, Friday, Saturday\n"
+ "Monday, Monday\n"
+ "Monday";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}