# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z0-9$%&*+\\/\-]//gm;t' <<< "WZ 123456--12.123.45678"