use strict;
my $str = 'WZ 123456--12.123.45678';
my $regex = qr/[^a-zA-Z0-9$%&*+\/\-]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";