package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z0-9$%&*+\/\-]`)
var str = `WZ 123456--12.123.45678`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}