#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/(?<domain>[^:\/\?,]*)"
Local $sString = "https://www.example.com:9090" & @CRLF & _
"https://abc.example-url.uk/username/test" & @CRLF & _
"https://test-url.web-url.ch/test" & @CRLF & _
"https://hello.example.co?test" & @CRLF & _
"https://test.example.com,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")