re = /https:\/\/(?<domain>[^:\/\?,]*)/m
str = 'https://www.example.com:9090
https://abc.example-url.uk/username/test
https://test-url.web-url.ch/test
https://hello.example.co?test
https://test.example.com,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end