const regex = /https:\/\/(?<domain>[^:\/\?,]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/(?<domain>[^:\\\/\\?,]*)', 'gm')
const str = `https://www.example.com:9090
https://abc.example-url.uk/username/test
https://test-url.web-url.ch/test
https://hello.example.co?test
https://test.example.com,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}