package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/(?<domain>[^:\/\?,]*)`)
var str = `https://www.example.com:9090
https://abc.example-url.uk/username/test
https://test-url.web-url.ch/test
https://hello.example.co?test
https://test.example.com,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}