#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<LAT>(?P>LONG))%2c(?<LONG>[\d-]{1,5}.*?\d{1,6}).*,(?<DATE>.*) S:(?<SPEED>.*?),Bat:(?<BAT>.*?) "
Local $sString = "http://maps.google.com/maps?q=65658.253568%2c-75.858586 V:A,21-12-01 21:37:32 S:0.0km/h,Bat:04 5110100692, p 73212, l: 7c, c:5216" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")