package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<LAT>(?P>LONG))%2c(?<LONG>[\d-]{1,5}.*?\d{1,6}).*,(?<DATE>.*) S:(?<SPEED>.*?),Bat:(?<BAT>.*?) `)
var str = `http://maps.google.com/maps?q=65658.253568%2c-75.858586 V:A,21-12-01 21:37:32 S:0.0km/h,Bat:04 5110100692, p 73212, l: 7c, c:5216
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}