// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<LAT>(?P>LONG))%2c(?<LONG>[\d-]{1,5}.*?\d{1,6}).*,(?<DATE>.*) S:(?<SPEED>.*?),Bat:(?<BAT>.*?) ").unwrap();
let string = "http://maps.google.com/maps?q=65658.253568%2c-75.858586 V:A,21-12-01 21:37:32 S:0.0km/h,Bat:04 5110100692, p 73212, l: 7c, c:5216
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}