using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<LAT>(?P>LONG))%2c(?<LONG>[\d-]{1,5}.*?\d{1,6}).*,(?<DATE>.*) S:(?<SPEED>.*?),Bat:(?<BAT>.*?) ";
string input = @"http://maps.google.com/maps?q=65658.253568%2c-75.858586 V:A,21-12-01 21:37:32 S:0.0km/h,Bat:04 5110100692, p 73212, l: 7c, c:5216
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}