use strict;
my $str = 'http://maps.google.com/maps?q=65658.253568%2c-75.858586 V:A,21-12-01 21:37:32 S:0.0km/h,Bat:04 5110100692, p 73212, l: 7c, c:5216
';
my $regex = qr/(?<LAT>(?P>LONG))%2c(?<LONG>[\d-]{1,5}.*?\d{1,6}).*,(?<DATE>.*) S:(?<SPEED>.*?),Bat:(?<BAT>.*?) /mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}