#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[a-z]+(?:_[a-z]+)*)(?<!_cat|_uom)\b"
Local $sString = "xxx_yyyyyy_zzz_aaaaa" & @CRLF & _
"xxx_cat_zzz_aaaaa" & @CRLF & _
"xxx_yyyyyy_zzz_aaaaa_cat" & @CRLF & _
"xxx_yyyyyy_zzz_aaaaa_uom"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")