import re
regex = re.compile(r"(?:[a-z]+(?:_[a-z]+)*)(?<!_cat|_uom)\b", flags=re.MULTILINE)
test_str = ("xxx_yyyyyy_zzz_aaaaa\n"
"xxx_cat_zzz_aaaaa\n"
"xxx_yyyyyy_zzz_aaaaa_cat\n"
"xxx_yyyyyy_zzz_aaaaa_uom")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")