const regex = /(?:[a-z]+(?:_[a-z]+)*)(?<!_cat|_uom)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[a-z]+(?:_[a-z]+)*)(?<!_cat|_uom)\\b', 'gm')
const str = `xxx_yyyyyy_zzz_aaaaa
xxx_cat_zzz_aaaaa
xxx_yyyyyy_zzz_aaaaa_cat
xxx_yyyyyy_zzz_aaaaa_uom`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}