re = /(?:[a-z]+(?:_[a-z]+)*)(?<!_cat|_uom)\b/m
str = 'xxx_yyyyyy_zzz_aaaaa
xxx_cat_zzz_aaaaa
xxx_yyyyyy_zzz_aaaaa_cat
xxx_yyyyyy_zzz_aaaaa_uom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end