#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?=.*\d+)(?=.*[\pL\pM\p{P}\p{S}]+)[\pL\pM\d\p{P}\p{S}]{6,}"
Local $sString = "1Ki77y" & @CRLF & _
".Susan53" & @CRLF & _
"jelly22fi$h" & @CRLF & _
"$m3llycat" & @CRLF & _
"a11Black$" & @CRLF & _
"!ush3r" & @CRLF & _
"&ebay.44" & @CRLF & _
"d3ltagamm@" & @CRLF & _
"!Lov3MyPiano" & @CRLF & _
"SterlingGmail20.15" & @CRLF & _
"BankLogin!3" & @CRLF & _
"اللغ٦٧" & @CRLF & _
"تال@#٦٧" & @CRLF & _
"ोे््््ॅऍॅ्र12" & @CRLF & _
"±±§§§§§§§§§"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")