using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\d+)(?=.*[\pL\pM\p{P}\p{S}]+)[\pL\pM\d\p{P}\p{S}]{6,}";
string input = @"1Ki77y
.Susan53
jelly22fi$h
$m3llycat
a11Black$
!ush3r
&ebay.44
d3ltagamm@
!Lov3MyPiano
SterlingGmail20.15
BankLogin!3
اللغ٦٧
تال@#٦٧
ोे््््ॅऍॅ्र12
±±§§§§§§§§§";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}