const regex = /(?=.*\d+)(?=.*[\pL\pM\p{P}\p{S}]+)[\pL\pM\d\p{P}\p{S}]{6,}/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.*\\d+)(?=.*[\\pL\\pM\\p{P}\\p{S}]+)[\\pL\\pM\\d\\p{P}\\p{S}]{6,}', 'gu')
const str = `1Ki77y
.Susan53
jelly22fi\$h
\$m3llycat
a11Black\$
!ush3r
&ebay.44
d3ltagamm@
!Lov3MyPiano
SterlingGmail20.15
BankLogin!3
اللغ٦٧
تال@#٦٧
ोे््््ॅऍॅ्र12
±±§§§§§§§§§`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}