import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\d+)(?=.*[\\pL\\pM\\p{P}\\p{S}]+)[\\pL\\pM\\d\\p{P}\\p{S}]{6,}";
final String string = "1Ki77y\n"
+ ".Susan53\n"
+ "jelly22fi$h\n"
+ "$m3llycat\n"
+ "a11Black$\n"
+ "!ush3r\n"
+ "&ebay.44\n"
+ "d3ltagamm@\n"
+ "!Lov3MyPiano\n"
+ "SterlingGmail20.15\n"
+ "BankLogin!3\n"
+ "اللغ٦٧\n"
+ "تال@#٦٧\n"
+ "ोे््््ॅऍॅ्र12\n"
+ "±±§§§§§§§§§";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}