use strict;
my $str = '1Ki77y
.Susan53
jelly22fi$h
$m3llycat
a11Black$
!ush3r
&ebay.44
d3ltagamm@
!Lov3MyPiano
SterlingGmail20.15
BankLogin!3
اللغ٦٧
تال@#٦٧
ोे््््ॅऍॅ्र12
±±§§§§§§§§§';
my $regex = qr/(?=.*\d+)(?=.*[\pL\pM\p{P}\p{S}]+)[\pL\pM\d\p{P}\p{S}]{6,}/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}