package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\.(\d{3})(\d+)`)
var str = `1.8789`
var substitution = "$1$2.$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}