const regex = /(\d+)\.(\d{3})(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\.(\\d{3})(\\d+)', 'gm')
const str = `1.8789`;
const subst = `$1$2.$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);