$re = '/(\d+)\.(\d{3})(\d+)/m';
$str = '1.8789';
$subst = "$1$2.$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;