use strict;
my $str = '1.8789';
my $regex = qr/(\d+)\.(\d{3})(\d+)/mp;
my $subst = '$1$2.$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";