import re
regex = re.compile(r"(\d+)\.(\d{3})(\d+)", flags=re.MULTILINE)
test_str = "1.8789"
subst = "$1$2.$3"
result = regex.sub(subst, test_str)
if result:
print(result)