#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)'(?:.* _\n)*.*"
Local $sString = "Hello Colm "This is a test""\\"" & @CRLF & _
""This is also an NL test"" & @CRLF & _
"" & @CRLF & _
"'And this has an escaped quote don\'t in it ' Blue Boy" & @CRLF & _
" " & @CRLF & _
"'euaoeu _" & @CRLF & _
"uaoeuaoeu _" & @CRLF & _
"uaoeuaoek" & @CRLF & _
"" & @CRLF & _
""This has a single quote ' but doesn\' end the quote as it started with double quotes" 'comment" & @CRLF & _
"" & @CRLF & _
""""line spanning with escaped quote at the end of a line""" 'comment" & @CRLF & _
"" & @CRLF & _
"""""" & @CRLF & _
"" & @CRLF & _
""Foo Bar" "Another Value" something else"
Local $sSubst = "'cmt"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)