$re = '/\'(?:.* _\n)*.*/m';
$str = 'Hello Colm "This is a test""\\\\"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
\'euaoeu _
uaoeuaoeu _
uaoeuaoek
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes" \'comment
"""line spanning with escaped quote at the end of a line""" \'comment
""""
"Foo Bar" "Another Value" something else';
$subst = "'cmt";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;