# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"'(?:.* _\n)*.*"
test_str = ("Hello Colm \"This is a test\"\"\\\\\"\n"
"\"This is also an NL test\"\n\n"
"'And this has an escaped quote don\\'t in it ' Blue Boy\n"
" \n"
"'euaoeu _\n"
"uaoeuaoeu _\n"
"uaoeuaoek\n\n"
"\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\" 'comment\n\n"
"\"\"\"line spanning with escaped quote at the end of a line\"\"\" 'comment\n\n"
"\"\"\"\"\n\n"
"\"Foo Bar\" \"Another Value\" something else")
subst = "'cmt"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.