import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'(?:.* _\\n)*.*";
final String string = "Hello Colm \"This is a test\"\"\\\\\"\n"
+ "\"This is also an NL test\"\n\n"
+ "'And this has an escaped quote don\\'t in it ' Blue Boy\n"
+ " \n"
+ "'euaoeu _\n"
+ "uaoeuaoeu _\n"
+ "uaoeuaoek\n\n"
+ "\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\" 'comment\n\n"
+ "\"\"\"line spanning with escaped quote at the end of a line\"\"\" 'comment\n\n"
+ "\"\"\"\"\n\n"
+ "\"Foo Bar\" \"Another Value\" something else";
final String subst = "'cmt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}