package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`img data-original="([^"]*)"`)
var str = `<img data-original="http://www.video.mediaset.it/bin/515.$plit/640x360_C_2_video_773293_videoThumbnail.jpg" alt="I vincitori di Maria Express" class="img-responsive lazy" width="323" height="186">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}