const regex = /img data-original="([^"]*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('img data-original="([^"]*)"', 'g')
const str = `<img data-original="http://www.video.mediaset.it/bin/515.\$plit/640x360_C_2_video_773293_videoThumbnail.jpg" alt="I vincitori di Maria Express" class="img-responsive lazy" width="323" height="186">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}