// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"img data-original="([^"]*)""#).unwrap();
let string = "<img data-original=\"http://www.video.mediaset.it/bin/515.$plit/640x360_C_2_video_773293_videoThumbnail.jpg\" alt=\"I vincitori di Maria Express\" class=\"img-responsive lazy\" width=\"323\" height=\"186\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}