re = /img data-original="([^"]*)"/
str = '<img data-original="http://www.video.mediaset.it/bin/515.$plit/640x360_C_2_video_773293_videoThumbnail.jpg" alt="I vincitori di Maria Express" class="img-responsive lazy" width="323" height="186">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end