#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^FLST,\d+,\d+,(\d),.*?$\n((^FITEM,\d+,\d+\s*$\n)+).*?(^[^\n]*?,P51X.*?$\n)"
Local $sString = "!* " & @CRLF & _
"CMDELE,_Y " & @CRLF & _
"CMDELE,_Y1 " & @CRLF & _
"CMDELE,_Y2 " & @CRLF & _
"!* " & @CRLF & _
"FLST,2,1,5,ORDE,1 " & @CRLF & _
"FITEM,2,33 " & @CRLF & _
"!* " & @CRLF & _
"/GO " & @CRLF & _
"DA,P51X,ALL," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"aplot " & @CRLF & _
"/UI,MESH,OFF" & @CRLF & _
"/inquire,aeChWmsy,psearch " & @CRLF & _
"/inquire,cGe7Wl8b,p" & @CRLF & _
"keyopt,etype_,1,1 " & @CRLF & _
"*SET,areas_,0 " & @CRLF & _
"FLST,5,2,5,ORDE,2 " & @CRLF & _
"FITEM,5,14 " & @CRLF & _
"FITEM,5,18 " & @CRLF & _
"ASEL,S, , ,P51X " & @CRLF & _
"asum" & @CRLF & _
"*get,x_,area,0,cent,x " & @CRLF & _
"*get,y_" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")