use strict;
my $str = '!*
CMDELE,_Y
CMDELE,_Y1
CMDELE,_Y2
!*
FLST,2,1,5,ORDE,1
FITEM,2,33
!*
/GO
DA,P51X,ALL,
aplot
/UI,MESH,OFF
/inquire,aeChWmsy,psearch
/inquire,cGe7Wl8b,p
keyopt,etype_,1,1
*SET,areas_,0
FLST,5,2,5,ORDE,2
FITEM,5,14
FITEM,5,18
ASEL,S, , ,P51X
asum
*get,x_,area,0,cent,x
*get,y_
';
my $regex = qr/^FLST,\d+,\d+,(\d),.*?$\n((^FITEM,\d+,\d+\s*$\n)+).*?(^[^\n]*?,P51X.*?$\n)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}