import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^FLST,\\d+,\\d+,(\\d),.*?$\\n((^FITEM,\\d+,\\d+\\s*$\\n)+).*?(^[^\\n]*?,P51X.*?$\\n)";
final String string = "!* \n"
+ "CMDELE,_Y \n"
+ "CMDELE,_Y1 \n"
+ "CMDELE,_Y2 \n"
+ "!* \n"
+ "FLST,2,1,5,ORDE,1 \n"
+ "FITEM,2,33 \n"
+ "!* \n"
+ "/GO \n"
+ "DA,P51X,ALL,\n\n\n"
+ "aplot \n"
+ "/UI,MESH,OFF\n"
+ "/inquire,aeChWmsy,psearch \n"
+ "/inquire,cGe7Wl8b,p\n"
+ "keyopt,etype_,1,1 \n"
+ "*SET,areas_,0 \n"
+ "FLST,5,2,5,ORDE,2 \n"
+ "FITEM,5,14 \n"
+ "FITEM,5,18 \n"
+ "ASEL,S, , ,P51X \n"
+ "asum\n"
+ "*get,x_,area,0,cent,x \n"
+ "*get,y_\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}