// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^FLST,\d+,\d+,(\d),.*?$\n((^FITEM,\d+,\d+\s*$\n)+).*?(^[^\n]*?,P51X.*?$\n)").unwrap();
let string = "!*
CMDELE,_Y
CMDELE,_Y1
CMDELE,_Y2
!*
FLST,2,1,5,ORDE,1
FITEM,2,33
!*
/GO
DA,P51X,ALL,
aplot
/UI,MESH,OFF
/inquire,aeChWmsy,psearch
/inquire,cGe7Wl8b,p
keyopt,etype_,1,1
*SET,areas_,0
FLST,5,2,5,ORDE,2
FITEM,5,14
FITEM,5,18
ASEL,S, , ,P51X
asum
*get,x_,area,0,cent,x
*get,y_
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}