# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\BN\B/-/gm;t' <<< "\"Peronospora boniNhenrici\",\"Cystoseira abiesNmarina\",\"Niplommatina rubra\",
\"Padina sanctaeNcrucis\",\"Nachygrapsus NaurusNliguricus\",\"Melphidippa borealis\""