re = /\BN\B/m
str = '"Peronospora boniNhenrici","Cystoseira abiesNmarina","Niplommatina rubra",
"Padina sanctaeNcrucis","Nachygrapsus NaurusNliguricus","Melphidippa borealis"'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result