const regex = /\BN\B/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\BN\\B', 'gm')
const str = `"Peronospora boniNhenrici","Cystoseira abiesNmarina","Niplommatina rubra",
"Padina sanctaeNcrucis","Nachygrapsus NaurusNliguricus","Melphidippa borealis"`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);