#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\BN\B"
Local $sString = ""Peronospora boniNhenrici","Cystoseira abiesNmarina","Niplommatina rubra"," & @CRLF & _
" "Padina sanctaeNcrucis","Nachygrapsus NaurusNliguricus","Melphidippa borealis""
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)