package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.*[\\\/])?src\/([^\/]*)\/?|\/([^\/\n]*)`)
var str = `/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth`
var substitution = "$1\\$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}