re = /(?:.*[\\\/])?src\/([^\/]*)\/?|\/([^\/\n]*)/m
str = '/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth'
subst = '$1\\\\$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result