const regex = /(?:.*[\\\/])?src\/([^\/]*)\/?|\/([^\/\n]*)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*[\\\\\\\/])?src\\\/([^\\\/]*)\\\/?|\\\/([^\\\/\\n]*)', 'mg')
const str = `/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth`;
const subst = `$1\\$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);