$re = '/(?:.*[\\\\\/])?src\/([^\/]*)\/?|\/([^\/\n]*)/m';
$str = '/dev/project/src/MVC/Models/Access/Auth
/home/user/dev/project/src/MVC/Models/Access/Auth
/any_other_folder/src/MVC/Models/Access/Auth';
$subst = "$1\\$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;