# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:.*[\\\/])?src\/([^\/]*)\/?|\/([^\/\n]*)"
test_str = ("/dev/project/src/MVC/Models/Access/Auth\n\n\n"
"/home/user/dev/project/src/MVC/Models/Access/Auth\n\n\n"
"/any_other_folder/src/MVC/Models/Access/Auth")
subst = "$1\\\\$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.