using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s=]+)=""([^""\\]*(?:\\[\w\W][^""\\]*)*)""";
string input = @"title=""Bonjour - \""(le monde))\"" style=""color: red;"" charset=""utf-8"" src=""monImage.png"" alt=""
tes-t6=""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}