// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"([^\s=]+)="([^"\\]*(?:\\[\w\W][^"\\]*)*)""#).unwrap();
let string = "title=\"Bonjour - \\\"(le monde))\\\"\" style=\"color: red;\" charset=\"utf-8\" src=\"monImage.png\" alt=\"\"
tes-t6=\"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}